re = /^[ \t]*\#(region|endregion).*\n/
str = '
#region
SqlConnection con = new SqlConnection(strConnString);
SqlDataAdapter da = new SqlDataAdapter();
da.SelectCommand = new SqlCommand("report_GetEuroRate", con);
da.SelectCommand.CommandType = CommandType.StoredProcedure;
DataSet ds = new DataSet();
da.Fill(ds, "EuroRateTbl");
DataTable dt = ds.Tables["EuroRateTbl"];
int count = dt.Rows.Count;
if (count > 0);
#endregion'
# Print the match result
str.match(re) do |match|
puts match.to_s
end