import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[ \\t]*\\#(region|endregion).*\\n";
final String string = "\n"
+ "#region\n"
+ " SqlConnection con = new SqlConnection(strConnString);\n"
+ " SqlDataAdapter da = new SqlDataAdapter();\n"
+ " da.SelectCommand = new SqlCommand(\"report_GetEuroRate\", con);\n"
+ " da.SelectCommand.CommandType = CommandType.StoredProcedure;\n"
+ " DataSet ds = new DataSet();\n"
+ " da.Fill(ds, \"EuroRateTbl\");\n"
+ " DataTable dt = ds.Tables[\"EuroRateTbl\"];\n"
+ " int count = dt.Rows.Count;\n"
+ " if (count > 0);\n\n"
+ "#endregion";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}