const regex = /<(\w*?)>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(\\w*?)>', 'g')
const str = `<soapenv:Envelope...>
   <soapenv:Header/>
   <soapenv:Body>
      <urn:ClosedRequest>
         <ExternalApplicationNumber>4816</ExternalApplicationNumber>
         <PersonDataList>
            <!--1 or more repetitions:-->
            <PersonData>
               <PersonExternalIdentifier>sa1</PersonExternalIdentifier>
               <EligibilityEndDate>2017-12-31</EligibilityEndDate>
               <!--Optional:-->
               <ReasonCode>60</ReasonCode>
               <PersonDeathDate>2015-09-02</PersonDeathDate>
            </PersonData>
         </PersonDataList>
      </urn:ClosedRequest>
   </soapenv:Body>
</soapenv:Envelope>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
    // This is necessary to avoid infinite loops with zero-width matches
    if (m.index === regex.lastIndex) {
        regex.lastIndex++;
    }
    
    // The result can be accessed through the `m`-variable.
    m.forEach((match, groupIndex) => {
        console.log(`Found match, group ${groupIndex}: ${match}`);
    });
}