import re
regex = re.compile(r"<(\w*?)>")
test_str = ("<soapenv:Envelope...>\n"
" <soapenv:Header/>\n"
" <soapenv:Body>\n"
" <urn:ClosedRequest>\n"
" <ExternalApplicationNumber>4816</ExternalApplicationNumber>\n"
" <PersonDataList>\n"
" <!--1 or more repetitions:-->\n"
" <PersonData>\n"
" <PersonExternalIdentifier>sa1</PersonExternalIdentifier>\n"
" <EligibilityEndDate>2017-12-31</EligibilityEndDate>\n"
" <!--Optional:-->\n"
" <ReasonCode>60</ReasonCode>\n"
" <PersonDeathDate>2015-09-02</PersonDeathDate>\n"
" </PersonData>\n"
" </PersonDataList>\n"
" </urn:ClosedRequest>\n"
" </soapenv:Body>\n"
"</soapenv:Envelope>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")