using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!\s)[^\p{Arabic}\r\n]+";
string input = @"این یک تست جدید است
fine just working line English my Is?
does it hope I...
این یک جمله جدید است English in continued be to is this and...";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}