re = /(?!\s)[^\p{Arabic}\r\n]+/
str = 'این یک تست جدید است
fine just working line English my Is?
does it hope I...
این یک جمله جدید است English in continued be to is this and...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end