# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\s?,\s?)(?=[^\(]*\))|(\s?,\s?)(?=(?:[^\(]*\([^\(]*?\))*\))/$/gm;t' <<< "SELECT 'column1' AS \"Column 1\" ,
'column2' AS \"Column 2\" ,
'column3' AS \"Column 3\",
SUM(Column_1, Column_2) , 'column5' AS \"Column 5\" ,
CONCAT(\"str1\",\"str2\",\"str3\") ,
ADD(len(str1),avg(column_1),sum(column_1,column_2,column_3)) "