# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\s?,\s?)(?=[^\(]*\))|(\s?,\s?)(?=(?:[^\(]*\([^\(]*?\))*\))"
test_str = ("SELECT 'column1' AS \"Column 1\" , \n"
" 'column2' AS \"Column 2\" , \n"
" 'column3' AS \"Column 3\", \n"
"SUM(Column_1, Column_2) , 'column5' AS \"Column 5\" ,\n"
"CONCAT(\"str1\",\"str2\",\"str3\") , \n"
"ADD(len(str1),avg(column_1),sum(column_1,column_2,column_3)) ")
subst = "$"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.