use strict;
my $str = 'SELECT \'column1\' AS "Column 1" ,
\'column2\' AS "Column 2" ,
\'column3\' AS "Column 3",
SUM(Column_1, Column_2) , \'column5\' AS "Column 5" ,
CONCAT("str1","str2","str3") ,
ADD(len(str1),avg(column_1),sum(column_1,column_2,column_3)) ';
my $regex = qr/(\s?,\s?)(?=[^\(]*\))|(\s?,\s?)(?=(?:[^\(]*\([^\(]*?\))*\))/mp;
my $subst = '$';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";