using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"J[a-z\s]+Neu";
string input = @"JNeu
JJJJJJJJNeu
Jenny Neu";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}