package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)J[a-z\s]+Neu`)
var str = `JNeu
JJJJJJJJNeu
Jenny Neu`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}