#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bLANG[\[\]\.'"]+plugins[\[\]\.'"]+[^\[\]\.'"]+[\]'"]*(?:\.(\w+)|\[['"](.*?)['"]\])"
Local $sString = "LANG.plugins.foo.string1; LANG['plugins']['foo']['string 2'];" & @CRLF & _
"" & @CRLF & _
"LANG.plugins['foo']['string 3']" & @CRLF & _
"" & @CRLF & _
"LANG.plugins['foo'].string4 + 'something';" & @CRLF & _
"" & @CRLF & _
"LANG.plugins.foo.string1;" & @CRLF & _
"" & @CRLF & _
"LANG.plugins['foo']['string 5'];" & @CRLF & _
"" & @CRLF & _
"LANG["plugins"]['foo']['string 5'];" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")