package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bLANG[\[\]\.'"]+plugins[\[\]\.'"]+[^\[\]\.'"]+[\]'"]*(?:\.(\w+)|\[['"](.*?)['"]\])`)
var str = `LANG.plugins.foo.string1; LANG['plugins']['foo']['string 2'];
LANG.plugins['foo']['string 3']
LANG.plugins['foo'].string4 + 'something';
LANG.plugins.foo.string1;
LANG.plugins['foo']['string 5'];
LANG["plugins"]['foo']['string 5'];
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}