$re = '/\bLANG[\[\]\.\'"]+plugins[\[\]\.\'"]+[^\[\]\.\'"]+[\]\'"]*(?:\.(\w+)|\[[\'"](.*?)[\'"]\])/m';
$str = 'LANG.plugins.foo.string1; LANG[\'plugins\'][\'foo\'][\'string 2\'];
LANG.plugins[\'foo\'][\'string 3\']
LANG.plugins[\'foo\'].string4 + \'something\';
LANG.plugins.foo.string1;
LANG.plugins[\'foo\'][\'string 5\'];
LANG["plugins"][\'foo\'][\'string 5\'];
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);