#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!^hello.*?123)(^.*$)"
Local $sString = "hello123abc" & @CRLF & _
"helloa123abc" & @CRLF & _
"hello123aabc" & @CRLF & _
"helloa123aabc" & @CRLF & _
"hello1abc" & @CRLF & _
"hello23abc" & @CRLF & _
"helloaabc" & @CRLF & _
"helloabc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")