using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!^hello.*?123)(^.*$)";
string input = @"hello123abc
helloa123abc
hello123aabc
helloa123aabc
hello1abc
hello23abc
helloaabc
helloabc";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}