package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{4}|\d{6})$`)
var str = `1234
a123
12345
123456
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}