import re
regex = re.compile(r"^(\d{4}|\d{6})$", flags=re.MULTILINE)
test_str = ("1234\n"
"a123\n"
"12345\n"
"123456\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")