$re = '/^(\d{4}|\d{6})$/m';
$str = '1234
a123
12345
123456
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);