const regex = /^(Subscription expiry changed) to (.*)/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(Subscription expiry changed) to (.*)', 'ig')
const str = `Subscription expiry changed to 13 Apr 2016`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}