$re = '/^(Subscription expiry changed) to (.*)/i';
$str = 'Subscription expiry changed to 13 Apr 2016';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);