#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "class=("|"([^"]*)\s)share("|\s([^"]*)")"
Local $sString = "<div class="share"></div>" & @CRLF & _
"<div class="sdfsd share sdfsdfsdf"></div>" & @CRLF & _
"<a class="share-s">" & @CRLF & _
"<div class="share sdfsdfsdf"></div>" & @CRLF & _
"<a class="sharen">" & @CRLF & _
"<div class="sdfsd share"></div>" & @CRLF & _
"<a class="icon-share export-to-csv-button">" & @CRLF & _
"<a class="fxac link" href="/share ">" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")