$re = '/class=("|"([^"]*)\s)share("|\s([^"]*)")/';
$str = '<div class="share"></div>
<div class="sdfsd share sdfsdfsdf"></div>
<a class="share-s">
<div class="share sdfsdfsdf"></div>
<a class="sharen">
<div class="sdfsd share"></div>
<a class="icon-share export-to-csv-button">
<a class="fxac link" href="/share ">
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);