using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"class=(""|""([^""]*)\s)share(""|\s([^""]*)"")";
string input = @"<div class=""share""></div>
<div class=""sdfsd share sdfsdfsdf""></div>
<a class=""share-s"">
<div class=""share sdfsdfsdf""></div>
<a class=""sharen"">
<div class=""sdfsd share""></div>
<a class=""icon-share export-to-csv-button"">
<a class=""fxac link"" href=""/share "">
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}