import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*(?:IpAddress(?!\":\"-)|WorkstationName)\":\"(?P<ipaddr>[^\"]+)";
final String string = "# IPADDR = 192.10.10.10\n"
+ "... \"WorkstationName\":\"WS-8300E-007\",\"IpAddress\":\"192.10.10.10\" ...\n\n"
+ "# IPADDR = WS-8300E-007\n"
+ "... \"WorkstationName\":\"WS-8300E-007\",\"IpAddress\":\"-\" ...";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}