const regex = /^.*(?:IpAddress(?!":"-)|WorkstationName)":"(?P<ipaddr>[^"]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*(?:IpAddress(?!":"-)|WorkstationName)":"(?P<ipaddr>[^"]+)', 'gm')
const str = `# IPADDR = 192.10.10.10
... "WorkstationName":"WS-8300E-007","IpAddress":"192.10.10.10" ...
# IPADDR = WS-8300E-007
... "WorkstationName":"WS-8300E-007","IpAddress":"-" ...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}