const regex = new RegExp('^(?:[1-9]|1[0-2])\\s*-\\s*(?:[1-9]|1[0-2])\\s*/\\s*2[01]\\d{2}$', 'gm')
const str = `1-6/2011`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}