using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<IP>\d+\.\d+\.\d+\.\d+)";
string input = @" [...] sent ping to 1.1.1.1:514 [...]
[...] paired node xxxxxx@2.2.2.2 [...]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}