$re = '/(?<IP>\d+\.\d+\.\d+\.\d+)/m';
$str = ' [...] sent ping to 1.1.1.1:514 [...]
[...] paired node xxxxxx@2.2.2.2 [...]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);