re = /(?<IP>\d+\.\d+\.\d+\.\d+)/m
str = ' [...] sent ping to 1.1.1.1:514 [...]
[...] paired node xxxxxx@2.2.2.2 [...]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end