use strict;
my $str = '1.456 substance';
my $regex = qr/((?:\d+\.)?\d+)\s/p;
my $subst = '$1*';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";