// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((?:\d+\.)?\d+)\s").unwrap();
let string = "1.456 substance";
let substitution = "$1*";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}