$re = '/((?:\d+\.)?\d+)\s/';
$str = '1.456 substance';
$subst = "$1*";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;