using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"word.*rude|rude.*word";
string input = @"My tweet contains rude words
This tweet has a rude word
Here is a word that is rude
But this word is totally legit and not bad";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}