package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)word.*rude|rude.*word`)
var str = `My tweet contains rude words
This tweet has a rude word
Here is a word that is rude
But this word is totally legit and not bad`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}