const regex = /word.*rude|rude.*word/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('word.*rude|rude.*word', 'gm')
const str = `My tweet contains rude words
This tweet has a rude word
Here is a word that is rude
But this word is totally legit and not bad`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}