const regex = /\{\{(.*?)\}\}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{\\{(.*?)\\}\\}', 'g')
const str = `<h1>{{title}}</h1>
<h3>{{subject}}</h3>
<p>Gentile <b>{{recipient.firstName}}</b> Benvenuto in CWay.</p>
<p>Siamo davvero entusiasti che hai deciso di provare i nostri servizi.</p>
<p>In caso di domande, non esitare a entrare in contatto con noi all\\'indirizzo <a href="mailto:{{recipient.email}}">{{recipient.email}}</a>.</p><p>Puoi accedere al tuo account con il nome utente {{recipient.userName}}.</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}