import re
regex = re.compile(r"\{\{(.*?)\}\}")
test_str = ("<h1>{{title}}</h1>\n"
"<h3>{{subject}}</h3>\n"
"<p>Gentile <b>{{recipient.firstName}}</b> Benvenuto in CWay.</p>\n"
"<p>Siamo davvero entusiasti che hai deciso di provare i nostri servizi.</p>\n"
"<p>In caso di domande, non esitare a entrare in contatto con noi all\\'indirizzo <a href=\"mailto:{{recipient.email}}\">{{recipient.email}}</a>.</p><p>Puoi accedere al tuo account con il nome utente {{recipient.userName}}.</p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")