re = /\{\{(.*?)\}\}/
str = '<h1>{{title}}</h1>
<h3>{{subject}}</h3>
<p>Gentile <b>{{recipient.firstName}}</b> Benvenuto in CWay.</p>
<p>Siamo davvero entusiasti che hai deciso di provare i nostri servizi.</p>
<p>In caso di domande, non esitare a entrare in contatto con noi all\\\'indirizzo <a href="mailto:{{recipient.email}}">{{recipient.email}}</a>.</p><p>Puoi accedere al tuo account con il nome utente {{recipient.userName}}.</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end