#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?: *(\d+(?:,\d+)?) *(?:x|$)){2}"
Local $sString = "200 x 90 x 14" & @CRLF & _
"90x200" & @CRLF & _
"200 x 90x20" & @CRLF & _
"60,4 x46,5 x 42,6" & @CRLF & _
"90x190,9"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")