using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?: *(\d+(?:,\d+)?) *(?:x|$)){2}";
string input = @"200 x 90 x 14
90x200
200 x 90x20
60,4 x46,5 x 42,6
90x190,9";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}