$re = '/(?: *(\d+(?:,\d+)?) *(?:x|$)){2}/m';
$str = '200 x 90 x 14
90x200
200 x 90x20
60,4 x46,5 x 42,6
90x190,9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);