package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?: *(\d+(?:,\d+)?) *(?:x|$)){3}`)
var str = `200 x 90 x 14
90x200
200 x 90x20
60,4 x46,5 x 42,6
90x190,9`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}