// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?: *(\d+(?:,\d+)?) *(?:x|$)){3}").unwrap();
let string = "200 x 90 x 14
90x200
200 x 90x20
60,4 x46,5 x 42,6
90x190,9";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}