const regex = new RegExp('^[0-9]{3}\\.?[0-9]{3}\\.?[0-9]{3}-?[0-9]$|^[0-9]{10}-?[0-9]$', '')
const str = `016.258.719-88`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}