$re = '/^[0-9]{3}\.?[0-9]{3}\.?[0-9]{3}-?[0-9]$|^[0-9]{10}-?[0-9]$/';
$str = '016.258.719-88';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);