re = /^[0-9]{3}\.?[0-9]{3}\.?[0-9]{3}-?[0-9]$|^[0-9]{10}-?[0-9]$/
str = '016.258.719-88'
# Print the match result
str.match(re) do |match|
puts match.to_s
end