using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^visite(?=(\d+))\1(?![a-z])";
string input = @"visite12345
--> is a good anwser (the string does match)
visite1a
--> is not a good anwser (the string doesn't match)
visite12345a
--> It doesn't work.the output is visite1234, whereas I'd like to get the same answer that for visite1a (string doesn't match";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}