const regex = /^visite(?=(\d+))\1(?![a-z])/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^visite(?=(\\d+))\\1(?![a-z])', 'gmi')
const str = `visite12345
--> is a good anwser (the string does match)
visite1a
--> is not a good anwser (the string doesn't match)
visite12345a
--> It doesn't work.the output is visite1234, whereas I'd like to get the same answer that for visite1a (string doesn't match`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}