import Foundation
let pattern = #"^visite(?=(\d+))\1(?![a-z])"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
visite12345
--> is a good anwser (the string does match)
visite1a
--> is not a good anwser (the string doesn't match)
visite12345a
--> It doesn't work.the output is visite1234, whereas I'd like to get the same answer that for visite1a (string doesn't match
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)